PHP and WHS

I completed the install of PHP and now none of my sites display. The site on my WHS are not PHP scripted. I get the error below. Any ideas anyone?

Appliance Error (internal_error)

An unrecoverable error was encountered: ""
This problem is unexpected. Please use the contact information below to obtain assistance.

Average rating
(0 votes)
Brashquido's picture

Location: Melbourne, Australia

Joined: Sep 2003

Send PM

Brashquido said:

WHS uses IIS 6, so the installation of PHP should not be any different, so I am unsure of why it would interfere with non php content. I'd suspect an incorrect IIS application mapping. To get your IIS server back on it's feet, I'd recommend doing a restore of your IIS metabase. Have a look at my guide on backing up and restoring your IIS 6 metabase for more information. Once you're done this post back and I'll do my best to help step you through installing PHP.

----------------
Dominic Ryan
4 x Microsoft IIS MVP, MCSE, MCSA
IIS Aid owner/webmaster

Taguero's picture

Location: Phoenix, AZ.

Joined: Mar 2009

Send PM

Taguero said:

I got my other sites up and running. In addition, I can access the one PHP scripted site I am building, but the PHP scirpt (for launching a blog page from a landing page)does not run as I get the standard 404 error (page cannot be found.

Stan

Brashquido's picture

Location: Melbourne, Australia

Joined: Sep 2003

Send PM

Brashquido said:

404 errors usually indicate a permissions issue. Make sure that your IIS user has at least NTFS read permissions to your blog.

----------------
Dominic Ryan
4 x Microsoft IIS MVP, MCSE, MCSA
IIS Aid owner/webmaster