404 Page not found after the installation with IIS Aid PHP installer

Categories:

Hello All,

I have used your IIS Aid PHP wizard installer in a Win2k3 SP2 system; without MySQL (I will it afterwards install). The Website directory (Webfarm) is located on a different hard disk (NOT in C:\inetpub). The Frontpage Server Extensions are installed.

After the installation (with FastCGI Handler) I have the following problem:
the browser give the message "404 Page not found" when I click the test file (http://###.###.###.###/phpinfo.php) target. But if I set the php extension in the mime type this was found!
The Address http://###.###.###.###/index.htm respond correctly.

I have also formed a new domain in IIS (with the fpse), but the phpinfo.php page is not found. The same problem as the default website.

All settings (except the mapping!) appear to be correct: PHP System variables are present (as path / pathext); your installation is present in the correct directory (C:\IIS-Aid\PHP)

The mapping cache isapi applications NOT contains the .php extension.

I have in the KB searched but no true precise information.

Average rating
(0 votes)
Brashquido's picture

Location: Melbourne, Australia

Joined: Sep 2003

Send PM

Brashquido said:

If you are getting 404 errors then as a first step I suggest checking the NTFS permissions on your php scripts. You will need at least NTFS read permissions for your IIS user account. A bit weird though if your .htm files are working, and you shouldn't have to touch your IIS mime mappings unless they have been altered previously to something incorrect. Have a look at this article about working with IIS mime types to see if anything is configured incorrectly here.
----------------
Dominic Ryan
4 x Microsoft IIS MVP, MCSE, MCSA
IIS Aid owner/webmaster

FritzMVP's picture

Location: Italy - Lake Garda

Joined: Feb 2009

Send PM

FritzMVP said:

Thank you for your reply!
After a careful control of all settings, I have noticed that some were not.

The IIS-Aid installer has not made the following settings:

http://learn.iis.net/page.aspx/248/configuring-fastcgi-extension-for-iis60/

After manually enter these settings the php test page have correctly answered.

They were not authentication problems.

Fritz MVP web editors
http://www.rausch.it
http://www.frontpageserver.de
Blog:
http://www.mt-01.org

Brashquido's picture

Location: Melbourne, Australia

Joined: Sep 2003

Send PM

Brashquido said:

Hi Fritz,

Which part did you have to do manually? If you had to do the PHP application mapping, that is an issue. However, if you are talking about making modifications to fcgiext.ini, then that is by design. By default the IIS Aid installer will install MS FastCGI with the default values. Glad to hear you got it sorted.
----------------
Dominic Ryan
4 x Microsoft IIS MVP, MCSE, MCSA
IIS Aid owner/webmaster